Web BizarroWeb Bizarro

Suscríbete a nuestro Newsletter

X

Únete a nuestra lista de correos para recibir semanalmente actualizaciones de nuestro contenido.

Medidas desesperadas para viejos browsers

Medidas desesperadas para viejos browsers 26.JUN.14

Alvaro José Rios Ch
Fundador WebBizarro

No se si a ustedes les ha pasado pero a mi un montón de veces, cuando hacemos una aplicación brutal y algún usuario reporta que no funciona por el simple hecho de estar viéndola en un navegador viejo (léase IE 6).

Pues este sitio web tiene una medida desesperada más que una solución, hay muchas cosas que podemos hacer para garantizar que el sitio funcione en múltiples navegadores pero hay momentos en que no nos queda nada más que hacer que pedir al usuario que actualice el navegador.

La forma de funcionar es bastante simple, cuando la página carga el script revisa si hay una propiedad CSS soportada por el navegador y en caso de que no sea así se muestra un mensaje indicando que el navegador debe ser actualizado.

Hay muchas formas de hacer esto pero este plug-in es muy simple de usar y visualmente llamativo así que esta muy interesante.

Para usarlo solo debes incluir el script y el archivo css, además incluir un pequeño tag html requerido. Para invocar el script puedes hacerlo de varias maneras, para hacerlo con Jquery puedes hacerlo de esta manera.

$( document ).ready(function() {
    outdatedBrowser({
        bgColor: '#f25648',
        color: '#ffffff',
        lowerThan: 'transform'
    });
});

Para comprobar la version del navegador se usan estas propiedades

Lower Than (<):

  • "IE11","borderImage"
  • "IE10", "transform" (Default property)
  • "IE9", "boxShadow"
  • "IE8", "borderSpacing"